Revel Systems Status

Freeway(FreedomPay) Transaction Processing Latency
Incident Report for Revel Systems
Resolved
FreedomPay outage has been resolved.
FreedomPay has resolved the transaction processing latency issues and all transaction processing has returned to normal.
Posted Dec 09, 2022 - 19:39 UTC
Update
Update how to operate offline:

1. Enable offline payment processing (https://support.revelsystems.com/s/article/Manual-Offline-Mode-on-the-Point-of-Sale-1582898972014) and stay on it until the outage is confirmed to be over;
2. Subscribe to status updates on https://status.freedompay.com/incidents/k0j608t6txnh or https://status.revelsystems.com/incidents/0smp1fb9lwkk;
3. Once the outage is confirmed to be over, upload POS databases (https://support.revelsystems.com/s/article/Sending-the-Database-1583161586035) from all stations.
Posted Dec 09, 2022 - 18:14 UTC
Investigating
FreedomPay is currently investigating reports of transaction processing latency with Freeway, FreedomPay's payment gateway. FreedomPay's Incident Response team is currently investigating the incident and will provide additional updates as soon as they arise.
Posted Dec 09, 2022 - 17:33 UTC
This incident affected: Payments Processing (FreedomPay).