Revel Systems Status

Incorrect idle screen on cardswipes
Incident Report for Revel Systems
Resolved
This incident has been resolved.
Posted Nov 03, 2023 - 18:22 UTC
Investigating
We are currently investigating the issue where "Cherry Tomatoes" appear on the cardswipe screen. The cardswipes do work as usual.
Posted Nov 03, 2023 - 18:03 UTC