Revel Systems Status

Valutec gift card processing issue
Incident Report for Revel Systems
Resolved
Worldpay technical resources resolved an internal license issue to restore service. Worldpay technical resources will continue to monitor the processing environment for stability.
Posted Apr 21, 2023 - 16:22 UTC
Investigating
There is an issue affecting ValuTec Gift Card processing on the Integrated Payments – Express, Integrated Payments - MercuryPay, and Worldpay Core Processing platforms. Some gift cards may decline
Posted Apr 21, 2023 - 16:13 UTC
This incident affected: Gift integrations (Valutec).