Revel Status

Delivery XT Service Disruption - Infrastructure Provider Issue

Incident Report for Revel Systems

Resolved

The issue has been resolved
Posted Jun 11, 2025 - 15:16 UTC

Identified

We are currently monitoring a potential service disruption to DeliveryXT due to an ongoing outage with one of our infrastructure providers. Our team is actively working with the provider to assess the impact and restore full service as quickly as possible. We will provide updates as more information becomes available.
Posted Jun 10, 2025 - 18:32 UTC
This incident affected: Delivery XT.