Revel Systems Status

Express & MercuryPay - Gift Card Transactions declining
Incident Report for Revel Systems
Resolved
Multiple clients confirmed that the system is back online and operational
Posted Mar 10, 2023 - 00:32 UTC
Monitoring
Worldpay technical resources resolved an internal database issue to restore service. Worldpay will continue to monitor the environment to ensure stability.
Posted Mar 10, 2023 - 00:04 UTC
Identified
There is an incident affecting gift card transactions on the Integrated Payments - Express and MercuryPay platforms that affects Valutec and worldpay gift cards
Posted Mar 09, 2023 - 23:56 UTC
This incident affected: Gift integrations (Valutec, Vantiv Storecard, Worldpay Storecard).