Revel Status

Clients not able to log in to the Management Console.
Incident Report for Revel Systems
Resolved
This incident has been resolved.
Posted Jun 13, 2023 - 21:04 UTC
Investigating
We are currently investigating the issue.
Posted Jun 13, 2023 - 19:41 UTC
This incident affected: Management Console (Core Services).