Revel Systems Status

RA XT payment processing deposit delay from January 1st and 2nd sales
Incident Report for Revel Systems
Resolved
This incident has been resolved.
Posted Jan 08, 2024 - 16:06 UTC
Monitoring
We received information from multiple merchants confirming that all the missing funds were deposited. Will be monitoring the issue until we confirm it is fully resolved.
Posted Jan 05, 2024 - 22:32 UTC
Identified
Our partner informed us that there was a delay in receiving deposits from the sales made on January 1st and 2nd, they confirmed that the funds were successfully processed and will be deposited Today (January 5th). We are continuing to monitor the issue and making sure all payments are being released
Posted Jan 05, 2024 - 16:20 UTC