Revel Status

Partial Support Call Line Outage

Incident Report for Revel Systems

Resolved

This incident has been resolved phone and chat systems are back online, service is restored to normal.
Posted Mar 23, 2025 - 18:18 UTC

Identified

The issue has been identified
Posted Mar 23, 2025 - 18:06 UTC

Investigating

We are aware of an issue with our phone system due to our third-party provider and are engaged in a resolution. In the interim please contact us via, email at support@revelsytems.com, or open a ticket via HelpSite support.revelsystems.com
We appreciate your patience as we work to resolve this issue.
Posted Mar 23, 2025 - 17:46 UTC
This incident affected: Customer Support.