Revel Systems Status

Valutec issues - Valutec Gift Card payments might get declined
Incident Report for Revel Systems
Resolved
Our partners confirmed that the issue was resolved without intervention from Worldpay technical resources. We confirmed that all operations are back online. Worldpay will continue to monitor the environment for stability.
Posted Feb 08, 2023 - 21:59 UTC
Investigating
Our partner WorldPay reported some ValuTec Gift Card processing issues on Integrated Payments - Express, MercuryPay and WorldPay core processing platforms. Some ValuTec gift card transactions may be declined.
Posted Feb 08, 2023 - 19:53 UTC
This incident affected: Gift integrations (Valutec).