Revel Systems Status

Telephony issues
Incident Report for Revel Systems
Resolved
This incident has been resolved.
Posted May 28, 2023 - 01:26 UTC
Investigating
We are currently investigating this issue.
Posted May 28, 2023 - 00:49 UTC
This incident affected: Customer Support.