Revel Systems Status

Transaction processing latency
Incident Report for Revel Systems
Resolved
This incident has been resolved.
Posted Oct 16, 2023 - 02:47 UTC
Investigating
FreedomPay is currently investigating reports of transaction processing latency and timeouts with Chase Paymentech.
Posted Oct 16, 2023 - 01:35 UTC
This incident affected: Payments Processing (FreedomPay).