Revel Status

Adyen - Online ordering checkout issues

Incident Report for Revel Systems

Resolved

This incident has been resolved.
Posted Apr 22, 2025 - 02:00 UTC

Investigating

Currently, Adyen is working on recovering checkout services, which are experiencing degraded performance
Posted Apr 21, 2025 - 23:45 UTC
This incident affected: Payments Processing (Adyen).