Revel Systems Status

Emails/Invoices fail to send from the POS
Incident Report for Revel Systems
Resolved
This incident has been resolved
Posted Feb 24, 2024 - 20:23 UTC
Identified
You might not be able to send an Emailed receipt or an Invoice from your POS. We are aware of the issue and working towards a resolution.
Posted Feb 23, 2024 - 20:56 UTC