Revel Systems Status

Tripos processing issues - transactions may decline
Incident Report for Revel Systems
Resolved
Worldpay support has confirmed that all services were restored and everything is back up and running.
Posted Mar 27, 2024 - 19:07 UTC
Monitoring
Transaction processing has returned to normal and all issues have been resolved. Monitoring the issue for now
Posted Mar 27, 2024 - 16:48 UTC
Investigating
Worldpay has reported an issue with payment processing through tripos, some transactions may decline
Posted Mar 27, 2024 - 16:48 UTC
This incident affected: Payments Processing (WorldPay TriPOS).