Revel Status

Minor server communication outage

Incident Report for Revel Systems

Resolved

This incident has been resolved.
Posted Feb 18, 2025 - 16:31 UTC

Monitoring

The fix has been implemented and is being applied.
We are actively continuing to monitor the issue.
Posted Feb 18, 2025 - 15:57 UTC

Identified

The issue has been identified and the fix is being tested.
Posted Feb 18, 2025 - 14:44 UTC

Investigating

We are currently investigating an issue with some POS devices failing to communicate to the server (this affects Online ordering and Loyalty platform use as well).

Please refrain from refreshing your POSs in the meantime and preferably please take payments using the offline mode functionality.

You can find more about it here: https://support.revelsystems.com/s/article/Offline-Mode-Always-On-Mode-1582898971418
Posted Feb 18, 2025 - 14:21 UTC
This incident affected: Management Console (Core Services) and Online Ordering XT, Loyalty XT, Delivery XT, Driver XT.