Revel Systems Status

Captain.AI/Delivery XT issue
Incident Report for Revel Systems
Resolved
This incident has been resolved.
Posted Jan 13, 2024 - 01:52 UTC
Investigating
We are currently investigating an issue with Captain.AI that directly affects the performance of Delivery XT.
Posted Jan 12, 2024 - 23:10 UTC
This incident affected: Delivery XT.