Revel Status

Telephony issues
Incident Report for Revel Systems
Resolved
The issue was resolved.
Posted Sep 24, 2024 - 18:06 UTC
Update
We are continuing to work on a fix for this issue.
Posted Sep 24, 2024 - 16:28 UTC
Identified
The issue has been identified, and we are working on a solution.
Posted Sep 24, 2024 - 16:09 UTC
Investigating
We are currently experiencing issues with the telephony system while calling customer support and other departments.
The issue is being investigated as we speak.
Scope: inbound calls sometimes go silent, however, we will call you back right away if this happens.
Posted Sep 24, 2024 - 15:36 UTC
This incident affected: Customer Support.