Revel Status

Punchh Loyalty reedeming issues
Incident Report for Revel Systems
Resolved
POS 2.80.8 version containing the fix to the issue has been released. The issue will be resolved by updating your POS application, please call our support line for assistance with the update process.
Posted Oct 06, 2024 - 17:27 UTC
Investigating
We are currently investigating an issue where redeeming Punchh loyalty causes issues on POS.
Posted Oct 05, 2024 - 23:46 UTC
This incident affected: Loyalty integrations (Punchh).