Revel Systems Status

Employee Cannot Clock-in to the POS station
Incident Report for Revel Systems
Resolved
This incident has been resolved.
Posted Mar 20, 2023 - 17:22 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 20, 2023 - 16:12 UTC
Investigating
We are currently investigating this issue. "Error, the employee did not clock out of previous shift”.
“Clock-in failed” errors appear as soon as you try to clock in. Our Engineers are actively working towards the resolution.
Posted Mar 20, 2023 - 16:12 UTC