Revel Systems Status

Adyen: Interac elevated error rate
Incident Report for Revel Systems
Resolved
Processing over Interac is back to normal since 00:54 CEST. We will continue monitoring and provide a new update if required.
Posted Oct 05, 2023 - 23:17 UTC
Investigating
Adyen has identified an issue outside of their platform resulting in an elevated error rate for transactions processed through Interac starting at 00:04 CEST. They have contacted Interac and will provide an update as soon as it becomes available. Some debit transactions may decline.
Posted Oct 05, 2023 - 22:42 UTC
This incident affected: Payments Processing (Adyen).