Revel Systems Status

Adyen payment gateway global outage
Incident Report for Revel Systems
Resolved
Adyen confirmed that the outage was resolved:
We can confirm that the reported connectivity issue resulting in elevated response times and degraded performance has recovered since 21:19 CET.
In the period between 20:15 and 21:19 CET, transactions processed over Adyen MasterCard acquiring could not be authorised. Additionally, for a small subset of transactions processed for other payment methods, merchants saw errors during this timeframe.
Posted Mar 16, 2023 - 21:25 UTC
Update
Adyen posted an update:
Our engineering team has scoped down the issue to a specific service within our platform. We have started to implemented a fix which we see it is improving performance as of 21:18 CET.
Posted Mar 16, 2023 - 20:33 UTC
Identified
Adyen payment gateway is experiencing a global outage. You may experience payments timing out or declining.
Message from Adyen:
We have identified an issue resulting in intermittent connectivity issues and degraded performance for merchants connecting to global endpoints starting at 20:15 CET.

Our engineering team has been engaged and is actively trying to resolve the situation.
Posted Mar 16, 2023 - 20:17 UTC
This incident affected: Payments Processing (Adyen).