Revel Systems Status

Issues logging to POS
Incident Report for Revel Systems
Resolved
This incident has been resolved.
Posted Dec 06, 2023 - 00:02 UTC
Monitoring
If you are experiencing an issue logging into the Revel POS dashboard, please update your POS stations to the latest POS version. The guidance on how to do it can be found on our Support website by searching the article called - Updating Your Revel iPad application.

https://support.revelsystems.com/s/article/Updating-Your-Revel-iPad-App
Posted Nov 13, 2023 - 14:01 UTC