Revel Status

Revel Data Connector Outage

Incident Report for Revel Systems

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 19, 2026 - 22:04 UTC

Identified

Currently, the Revel Data connector is experiencing a partial outage.
The functionality is limited, and the data present is not complete.
The underlying issue has been identified, and a fix is being implemented.
Posted Jun 19, 2026 - 15:19 UTC
This incident affects: Revel Data Connector.