Revel Systems Status

(FreedomPay) Transaction latency and timeouts using First Data Nashville
Incident Report for Revel Systems
Resolved
The gateway has observed that Discover card transactions have resumed processing normally through all processors. The gateway encountered errors processing Discover Cards between 1:17 PM CDT through 4:22 PM CDT
Posted Feb 06, 2023 - 22:51 UTC
Identified
Our partners informed that the transaction latency issue is caused by The Discover Network datacenter failure. The Discover Network continues to experience issues but transaction processing is stabilizing.
Posted Feb 06, 2023 - 22:08 UTC
Investigating
FreedomPay is currently investigating reports of transaction processing latency and timeouts with First Data Nashville. Support teams are currently investigating the incident and FreedomPay will continue to provide updates to its clients. If you are experiencing any issues with Payment processing, please enable Offline Mode as per the article below:

https://support.revelsystems.com/s/article/Offline-Mode-Always-On-Mode-1582898971418
Posted Feb 06, 2023 - 20:40 UTC
This incident affected: Payments Processing (FreedomPay).