Revel Status

Telephony issues

Incident Report for Revel Systems

Resolved

The issue has been resolved.
Posted Aug 19, 2025 - 00:19 UTC

Investigating

We are currently experiencing telephony issues, and we are not reachable via our standard phone number.

For support, please use: +1 (833) 437-3835 or send us an email at support@revelsystems.com
Posted Aug 18, 2025 - 23:27 UTC
This incident affected: Customer Support.