Revel Systems Status

RA XT email: "Banking information adjustment"
Incident Report for Revel Systems
Resolved
This incident has been resolved.
Posted Dec 06, 2023 - 16:08 UTC
Identified
Please be informed that this is an intentional change, we are adjusting bank account types (not the information on the accounts) for other features to work. You can rest assure that neither deposits or the banking information will be affected.
Posted Dec 05, 2023 - 20:46 UTC