Revel Status

CloudFlare outage

Incident Report for Revel Systems

Resolved

The outage has been resolved and functionality restored.
Posted Nov 18, 2025 - 14:48 UTC

Investigating

Currently, due to the CloudFlare, there are some system accessibility issues with certain Revel services.
Currently, the most affected is the payment portal (accessible at portal.revelup.com)

We are monitoring the situation.
Posted Nov 18, 2025 - 14:09 UTC
This incident affected: Revel Advantage Merchant Portal.