Revel Systems Status

Support phone line degraded performance
Incident Report for Revel Systems
Resolved
This incident has been resolved.
Posted Feb 22, 2024 - 19:02 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 22, 2024 - 18:48 UTC
Investigating
Our general support phone line temporarily having issues, you might not be able to give us a call using our General Support phone line.

Please submit your case via support@revelsystems.com
Posted Feb 22, 2024 - 18:32 UTC
This incident affected: Customer Support.