Revel Systems Status

Paytronix outage
Incident Report for Revel Systems
Resolved
This incident has been resolved.
Posted Apr 03, 2024 - 00:45 UTC
Investigating
Paytronix users might be experiencing issues of degraded performance. The issue is being investigated.
Posted Apr 02, 2024 - 23:38 UTC
This incident affected: Loyalty integrations (Paytronix).