Revel Status

Support call line down
Incident Report for Revel Systems
Resolved
This incident has been resolved.
Posted Aug 11, 2024 - 23:29 UTC
Investigating
We're currently experiencing an issue with our support call line, which is temporarily unavailable.
Our team is working to resolve this as quickly as possible.
We apologize for any inconvenience this may cause and appreciate your patience.
Please check back here for updates, for support inquiries please reach out to us via email (support@revelsystems.com) or through our Help Site in the meantime. Thank you for your understanding.
Posted Aug 11, 2024 - 23:14 UTC
This incident affected: Customer Support.