Revel Status

Phone System Interruption

Incident Report for Revel Systems

Resolved

The incident has been resolved and all systems are operational.
Posted Jun 02, 2026 - 22:03 UTC

Monitoring

Currently, the telephony is operational, but we are continuing to monitor the situation.
Posted Jun 02, 2026 - 21:45 UTC

Identified

Revel is aware of an issue affecting our phone systems. We are working to resolve this issue as quickly as possible.

We will provide updates as they become available.

Thanks for your patience; we apologize for the inconvenience.
Posted Jun 02, 2026 - 15:54 UTC
This incident affected: Customer Support.