Revel Systems Status

Givex gift cards partial outage
Incident Report for Revel Systems
Resolved
The Givex outage is resolved. Givex-related operations are back to normal.
Posted Dec 12, 2023 - 20:08 UTC
Monitoring
Givex operations are going back to normal. The situation is being monitored.
Posted Dec 12, 2023 - 20:03 UTC
Investigating
The issue is currently being investigated. Givex-related operations are currently disrupted.
Posted Dec 12, 2023 - 19:32 UTC
This incident affected: Gift integrations (Givex).