Revel Systems Status

Online ordering XT is affected by performance issues.
Incident Report for Revel Systems
Resolved
This incident have been resolved
Posted Oct 13, 2023 - 22:58 UTC
Monitoring
A fix has been implemented and Online Ordering XT is back up.
We are monitoring the situation
Posted Oct 13, 2023 - 22:52 UTC
Investigating
We are currently investigating issues with Online ordering XT.
Posted Oct 13, 2023 - 22:22 UTC
This incident affected: Online Ordering XT.