Revel Status

Revel Chat Service Disruption

Incident Report for Revel Systems

Resolved

This incident has been resolved.
Posted Jul 03, 2025 - 00:25 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Jul 02, 2025 - 21:03 UTC

Investigating

We are currently experiencing an issue affecting client access to Revel Chat via the Helpsite.
Merchants requiring assistance are encouraged to contact us directly at support@revelsystems.com.

We apologize for any inconvenience this may cause and appreciate your patience and understanding.
Further updates will be provided promptly as more information becomes available.
Posted Jul 02, 2025 - 21:02 UTC
This incident affected: Customer Support.