Revel Systems Status

Telephony system issue
Incident Report for Revel Systems
Resolved
The issue has been resolved. Telephony system is back up for all regions.
Posted Apr 05, 2023 - 19:10 UTC
Investigating
We are currently having an issue with our telephony system and some regions might not be able to call in. If you need immediate support, please create a ticket via Help site support.revelsystems.com or contact our Chat support for immediate response.
Posted Apr 05, 2023 - 14:53 UTC
This incident affected: Customer Support.