Revel Status

RA XT deposit delay for November 20th sales
Incident Report for Revel Systems
Resolved
This incident has been resolved.
Posted Nov 23, 2024 - 00:39 UTC
Monitoring
The impacted transactions have been funded and will be included in the next payout cycle today for the affected merchants.
Posted Nov 22, 2024 - 19:30 UTC
Investigating
We are investigating a deposit delay that is impacting RA XT merchants. Payouts failed to generate on time, deposits for November 20th sales are affected and experiencing a delay
Posted Nov 22, 2024 - 17:34 UTC
This incident affected: Revel Advantage Merchant Portal.