Revel Status

Gift cards cannot be redeemed on Online Ordering XT

Incident Report for Revel Systems

Resolved

The issue has been resolved.
Posted Mar 15, 2023 - 18:35 UTC

Identified

The issue has been identified and we are currently working on getting it fixed.
Posted Mar 15, 2023 - 17:27 UTC

Investigating

We are currently investigating the issue
Posted Mar 15, 2023 - 17:17 UTC
This incident affected: Online Ordering XT.