Revel Status

WorldPay/ TriPOS outage

Incident Report for Revel Systems

Resolved

This incident has been resolved.
Posted Aug 31, 2025 - 14:28 UTC

Investigating

Hello,

Currently, WorldPay is experiencing an outage; therefore, payment operations will be affected.
Posted Aug 31, 2025 - 14:08 UTC
This incident affected: Payments Processing (WorldPay TriPOS).