Revel Status

NetSuite Service Partial Outage

Incident Report for Revel Systems

Resolved

This incident has been resolved.
Posted Feb 15, 2023 - 17:09 UTC

Identified

Our partners NetSuite have a partial outage that might affect processing orders on Netsuite, Payment method submission, Order Fulfillment, and Shipping as well as accessing Billing Tab on the Management Console.
The services are expected to be restored by 8 am PST.
Posted Feb 15, 2023 - 15:30 UTC

Monitoring

Our partners NetSuite have a partial outage that might affect processing orders on Netsuite, Payment method submission, Order Fulfillment, and Shipping as well as accessing Billing Tab on the Management Console.
The services are expected to be restored by 8 am PST.
Posted Feb 15, 2023 - 14:57 UTC
This incident affected: Management Console (Core Services).