Revel Status

RA XT 1 day deposit delay - September 24th
Incident Report for Revel Systems
Resolved
This incident has been resolved.
Posted Sep 26, 2024 - 17:37 UTC
Identified
Our partners informed us that some merchants may experience a 1 day deposit delay, we are investigating the issue and will provide more information with next status update
Posted Sep 24, 2024 - 19:15 UTC