Revel Status

Delay in Revel Advantage XT Funding Delay for October 13th

Incident Report for Revel Systems

Resolved

This incident has been resolved.
Posted Oct 14, 2025 - 17:14 UTC

Identified

There was a delay with the funding schedule due to the Bank Holiday (Columbus Day), the issue has been resolved and all payouts were processed. Funds are expected to be deposited to the bank by the end of today, October 14.
Posted Oct 14, 2025 - 13:39 UTC
This incident affected: Payments Processing (WorldPay TriPOS).