Revel Status

Issues with emailing
Incident Report for Revel Systems
Resolved
The emailing issue has been resolved. All the operations are back to normal.
Posted Jun 01, 2024 - 00:47 UTC
Investigating
We do apologize but currently, we are experiencing degraded performance of our emailing system. As a result of that, you might not results of that, temporarily you will not receive emails from us.

Nothing else is affected, we continue to provide support on the calls.
Posted Jun 01, 2024 - 00:29 UTC
This incident affected: Customer Support.