Revel Status

Issue with Australian and Toronto Support Lines

Incident Report for Revel Systems

Identified

We are aware that the Australian Help Line (+61 2 8520 3344) and Toronto line (+1 647 313 3117) are currently unavailable and return a suspension message, ‘The number you are calling is currently suspended.’
For urgent assistance, please email us at support@revelsystems.com

Until further notice, please use the following numbers:
Canada/Toronto: +1 469 405 0185
Australia: international numbers: +1 (833) 437-3835 or +1 (415) 744-1433
Posted Oct 01, 2025 - 21:27 UTC

Investigating

We are aware that calls to the Australian Help Line at +61 2 8520 3344 return the message:
‘The number you are calling is currently suspended.’ At this time, Support is not reachable through this line.
If urgent assistance is required while the phone line is unavailable, please contact us via email at support@revelsystems.com
Posted Oct 01, 2025 - 02:56 UTC
This incident affects: Customer Support.