Revel Status

RA XT Partial deposits received for Mondays sales 9-23
Incident Report for Revel Systems
Resolved
This incident has been resolved.
Posted Sep 26, 2024 - 17:38 UTC
Identified
Today, 9/25, there was an issue with the delta eMAF that caused subset of transactions from September 23rd to be paid on time, but the payouts were underfunded.The subset of impacted card present transactions underfunded today will be funded during standard payouts tomorrow 9/26.
Posted Sep 25, 2024 - 21:34 UTC