Revel Systems Status

FreedomPay Transaction Processing degradation.
Incident Report for Revel Systems
Resolved
This incident has been resolved. FreedomPay has resolved the transaction processing latency issues and all transaction processing has returned to normal.
Posted Jan 27, 2024 - 17:54 UTC
Investigating
We are currently investigating this issue as there are declined reports.
Posted Jan 27, 2024 - 17:42 UTC
This incident affected: Payments Processing (FreedomPay).