Revel Status

Single server outage

Incident Report for Revel Systems

Resolved

Root cause has been identified and functionality has been restored.
Monitoring for any changes.
Posted Nov 07, 2025 - 14:50 UTC

Investigating

Currently, a single server is experiencing issues and is inaccessible for use by customers of Black Rock Coffee Bar.
We are investigating the root cause.
Posted Nov 07, 2025 - 14:40 UTC
This incident affected: Management Console (Core Services).