Revel Status

RA XT Users Received a Password Reset Email
Incident Report for Revel Systems
Resolved
As indicated earlier today, we received reports of RA XT portal users receiving unexpected password reset emails. You and your merchants should disregard the request to reset your password.

We believe bad actors used publicly available information to send these requests. At this time, we have no evidence of account compromise and will communicate as appropriate if that were to change.

Please know we have put additional security measures in place to help prevent this from recurring.
Posted Aug 16, 2024 - 22:35 UTC
Identified
There were password reset attempts by malicious users. We are working to block the source. We have confirmed this is a bot request and no data has been compromised.

In the meantime, if users receive an unexpected request to reset their password, please disregard.
Posted Aug 16, 2024 - 17:10 UTC
Investigating
We received reports of portal users receiving unexpected password reset emails.

Investigating why these were sent out.
Posted Aug 16, 2024 - 15:30 UTC
This incident affected: Revel Advantage Merchant Portal.