Revel Status

Delay in Revel Advantage XT Statements (July)

Incident Report for Revel Systems

Resolved

The incident has been resolved. Merchant statements are available to be downloaded again.
Posted Aug 26, 2025 - 17:54 UTC

Monitoring

A fix has been applied and July invoices should appear under "Payments" tab on Management console. We are closely monitoring results.
Posted Aug 24, 2025 - 16:38 UTC

Investigating

We are currently experiencing a technical issue affecting the generation of July statements for Revel Advantage XT. As a result, merchant statements are temporarily unavailable in the Management Console.
Our engineering teams are actively investigating and working to resolve the issue as quickly as possible.
We apologize for the inconvenience and appreciate your patience while we work to restore full functionality.
Posted Aug 07, 2025 - 20:35 UTC
This incident affected: Revel Advantage Merchant Portal.