Revel Status

Telephony issues

Incident Report for Revel Systems

Resolved

The incident has been resolved.
Posted Apr 24, 2025 - 15:12 UTC

Monitoring

The issues have been resolved. We are actively monitoring the situation, and all phone numbers are operational.
Posted Apr 24, 2025 - 14:40 UTC

Identified

We have identified the issue and are working on a fix.

In the meantime, please use this number to reach out: +1 415 744 1433

Otherwise, you can also reach out using the chat functionality: https://support.revelsystems.com/s/contactsupport
Posted Apr 24, 2025 - 14:28 UTC

Investigating

Currently, the Revel support phone numbers are experiencing an issue.
We are investigating and will have an update soon.
In the meantime, if your request is with the Customer support departments of Revel please reach out via email and we will respond as soon as possible.
You can submit a ticket here: https://support.revelsystems.com/s/contactsupport
Posted Apr 24, 2025 - 13:42 UTC
This incident affected: Customer Support.