Revel Systems Status

Settings tab on the Management Console is not accessible
Incident Report for Revel Systems
Resolved
This incident has been resolved.
Posted Feb 20, 2023 - 10:36 UTC
Investigating
We are currently investigating this issue
Posted Feb 20, 2023 - 07:45 UTC
This incident affected: Management Console (Core Services).